Ionic ResearchKit

Ionic ResearchKit

Make ResearchKit Apps for iOS and Android

Free!

(1)
Nino Guba

Nino Guba

Member since 2015

Details

Version:
0.1
Size:
0mb
Ionic:
1.0.0,1.0.1
Platforms:
iOS, Android
View ID:
c9276c30
Released:
5 years ago
Updated:
5 years ago
Category:
Plugins
Tags:
research, medical, health, researchkit

Ionic ResearchKit

An open source plugin equivalent of Apple's ResearchKit Framework built on Ionic which makes it easy to create cross-platform hybrid native apps for medical research or for other research projects.

Fork it on Github - https://github.com/ninoguba/ionic-researchKit

Note: To get started, check out the Ionic ResearchKit Starter

Hey there! You'll need to log in before you can leave a comment here.

Fernando Fabreti

Fernando Fabreti   ·   5 years ago

Hey Nino, Thank you for your code! Really helpfull!

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

How do I install this plugin - specifically for Ionic 2

Nino Guba

Nino Guba   ·   3 years ago

Please refer to the instructions here: https://market.ionic.io/starters/ionic-researchkit-starter Note however that this plugin has not been tested with Ionic 2++.

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

How would I use this plugin with an existing app though? Those instruction seem just to be to download and setup the starter project.

Nino Guba

Nino Guba   ·   3 years ago

Installation and usage instructions are on Github: https://github.com/ninoguba/ionic-researchKit

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

Thank you, but sorry, I'm new to Ionic - I've downloaded the .js and .css files (i.e. the first two steps) but I'm unsure of where/in what file to put the last line ('angular.module('myApp', ['ionicResearchKit']);'). And without that line, I get errors like this when trying to use the framework: compiler.es5.js:1694 Uncaught Error: Template parse errors: 'irk-task' is not a known element: 1. If 'irk-task' is an Angular component, then verify that it is part of this module. 2. If 'irk-task' is a Web Component then add 'CUSTOM_ELEMENTS_SCHEMA' to the '@NgModule.schemas' of this component to suppress this message. Any help would be much appreciated.

Nino Guba

Nino Guba   ·   3 years ago

If you are using Ionic 2+ then it is also dependent on Angular 2+. As noted, this plugin is not compatible with those latest versions yet. If you want to use the plugin, you'll need to drop down to Ionic 1.3.

  ·   just now

{{ reply.comment }}



Hey there! You'll need to log in before you can leave a comment here.

  ·   just now

{{ comment.comment }}

  ·   just now

{{ reply.comment }}



Hey there! You'll need to log in before you can leave a comment here.

  ·   just now

{{ comment.comment }}

  ·   just now

{{ reply.comment }}



Hey there! You'll need to log in before you can leave a comment here.

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

How do I install this plugin - specifically for Ionic 2

Nino Guba

Nino Guba   ·   3 years ago

Please refer to the instructions here: https://market.ionic.io/starters/ionic-researchkit-starter Note however that this plugin has not been tested with Ionic 2++.

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

How would I use this plugin with an existing app though? Those instruction seem just to be to download and setup the starter project.

Nino Guba

Nino Guba   ·   3 years ago

Installation and usage instructions are on Github: https://github.com/ninoguba/ionic-researchKit

Tibor Rothschild

Tibor Rothschild   ·   3 years ago

Thank you, but sorry, I'm new to Ionic - I've downloaded the .js and .css files (i.e. the first two steps) but I'm unsure of where/in what file to put the last line ('angular.module('myApp', ['ionicResearchKit']);'). And without that line, I get errors like this when trying to use the framework: compiler.es5.js:1694 Uncaught Error: Template parse errors: 'irk-task' is not a known element: 1. If 'irk-task' is an Angular component, then verify that it is part of this module. 2. If 'irk-task' is a Web Component then add 'CUSTOM_ELEMENTS_SCHEMA' to the '@NgModule.schemas' of this component to suppress this message. Any help would be much appreciated.

Nino Guba

Nino Guba   ·   3 years ago

If you are using Ionic 2+ then it is also dependent on Angular 2+. As noted, this plugin is not compatible with those latest versions yet. If you want to use the plugin, you'll need to drop down to Ionic 1.3.

  ·   just now

{{ reply.comment }}



Hey there! You'll need to log in before you can leave a comment here.

Fernando Fabreti

Fernando Fabreti   ·   5 years ago

Hey Nino, Thank you for your code! Really helpfull!

Hey there! You'll need to log in before you can leave a rating here.

Fernando Fabreti   ·     ·   5 years ago

Nice wrap-up! Of course there is room for improvement, but well done.

  ·     ·   just now

{{ rating.comment }}

  ·     ·   just now

{{ rating.comment }}

Fernando Fabreti    ·     ·   5 years ago

Nice wrap-up! Of course there is room for improvement, but well done.